Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 10 von 13

Thema: layout problem

  1. #1
    Neuer Benutzer Newbie
    Registriert seit
    20.10.2006
    Beiträge
    18

    Standard layout problem

    hey leute, ich möchte gern, das mann auf meiner homepage das layout sieht. das ist der html-code:

    <frameset rows="80,*" frameborder="no" border="1" framespacing="0">
    <frame src="header.html" name="topFrame" scrolling="No" noresize="noresize" id="topFrame" title="header" target="_self" />
    <frameset rows="*" framespacing="0" frameborder="no" border="1">
    <frameset cols="164,*" framespacing="0" frameborder="no" border="1">
    <frame src="left.html" name="leftFrame" scrolling="No" noresize="noresize" id="leftFrame" title="left" target="_self" />
    <frame src="main.html" name="mainFrame" id="mainFrame" title="mainFrame" target="_self" />



    stimmt doch alles oder??


    man sieht es aber nicht im browser...

    hier die homepage: www.mofatuning24.ch.vu

  2. #2
    Erfahrener Benutzer Profi Member Avatar von Jürgen
    Registriert seit
    11.11.2003
    Beiträge
    7.716

    Standard

    Hallo,

    das ist auch nur das Frameset. In den darin enthaltenen HTML-Seiten müssen die Hintergrundbilder rein. Natürlich müssen auch die einzelnen Seiten des Framesets erstellt werden
    Lade dir in meinem Downloadbereich "Webtemplates" die Frames runter und schau dir den Quelltext an, dann mekst Du schon was los ist...hier>>

    Auch mein kleiner HTML-Workshop wird für Dich hilfreich sein.

    Bis dann
    Jürgen

  3. #3
    Neuer Benutzer Newbie
    Registriert seit
    20.10.2006
    Beiträge
    18

    Standard

    hier mal der ganze index.html:
    !DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Frameset//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-frameset.dtd">
    <html xmlns="http://www.w3.org/1999/xhtml">
    <head>
    <meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1" />
    <title>Unbenanntes Dokument</title>
    </head>

    <frameset rows="80,*" frameborder="no" border="1" framespacing="0">
    <frame src="header.html" name="topFrame" scrolling="No" noresize="noresize" id="topFrame" title="header" target="_self" />
    <frameset rows="*" framespacing="0" frameborder="no" border="1">
    <frameset cols="164,*" framespacing="0" frameborder="no" border="1">
    <frame src="left.html" name="leftFrame" scrolling="No" noresize="noresize" id="leftFrame" title="left" target="_self" />
    <frame src="main.html" name="mainFrame" id="mainFrame" title="mainFrame" target="_self" />
    </frameset>
    </frameset>
    </frameset>
    <noframes><body>
    </body>
    </noframes></html>





    komm irgendwie nicht nach....


    und noch etwas: wenn ich im frontpage oder auch dreamweaver ein bild einfüge, kann ich das bild in den programmen ansehen, aber im browser ist nur ein kreuz dort... wieso das?

  4. #4
    Erfahrener Benutzer Profi Member Avatar von Jürgen
    Registriert seit
    11.11.2003
    Beiträge
    7.716

    Standard

    Hallo,

    die index, also das Frameset interessiert nicht. Du mußt die Seiten bearbeiten, die in das Frameset geladen werden, also die header.html, left.html u.s.w.

    Lerne mal etwas HTML und schau dir das an was ich bereits oben gepostet habe. Hier noch ein weiterer Link für dich, denn dort siehst Du, wie Hintergrundbilder in den einzelnen Frameseiten eingefügt werden klick>> ...

    Wenn Du dir diesen Workshop wirklich durchgelesen hast, dann weisst Du wie es geht.

    gruß
    Jürgen

  5. #5
    Neuer Benutzer Newbie
    Registriert seit
    20.10.2006
    Beiträge
    18

    Standard

    jürgen, schau jetzt mal: www.mofatuning24.ch.vu

    wegen dem layout es ist gegangen.

  6. #6
    Erfahrener Benutzer Profi Member Avatar von Jürgen
    Registriert seit
    11.11.2003
    Beiträge
    7.716

    Standard

    Hallo,

    wenn Du das Grau meinst, das war vorhin auch schon da, nur jetzt hast Du im Frameset wohl die Border auf 1 gesetzt, damit die weissen Abgrenzungen zu den einzelnen Frames zu sehen sind.

    Leider stören auch Werbeeinblendungen, aber ok, das muß man wohl bei einem kostenlosen Anbieter in Kauf nehmen.

    Bis dann
    Jürgen

  7. #7
    Neuer Benutzer Newbie
    Registriert seit
    20.10.2006
    Beiträge
    18

    Standard

    eben, wieso werden bei mir die bilder nicht angezeigt?
    hier der code:
    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
    <html xmlns="http://www.w3.org/1999/xhtml">
    <head>
    <meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1" />
    <title>Unbenanntes Dokument</title>
    <style type="text/css">
    <!--
    body,td,th {
    color: #FFFFFF;
    }
    body {
    background-color: #000000;
    }
    .Stil1 { font-family: Arial, Helvetica, sans-serif;
    font-size: 16px;
    color: #FFFF00;
    font-weight: bold;
    }
    -->
    </style></head>

    <body background="rock134.jpg">
    <div align="center"><span class="Stil1">
    <font face="Arial Black" size="3" color="#FF0000">ZUM VERKAUFEN:</font></span></div>
    <div align="center">&nbsp;</div>
    <p><u><span class="Stil1"><font face="Arial Black" color="#FF0000">
    Anhängerkupplung Haerri</u>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; &nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&n bsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbs p;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; &nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&n bsp;
    <u>&nbsp; </u></font></span></p>
    <p><span class="Stil1"><font face="Arial Black" color="#FF0000">Ist in einem
    gebrauchtem Zustand</font></span></p>
    <p><span class="Stil1"><font face="Arial Black" color="#FF0000">Preis: <u>20CHF</u></font></span></p>
    <div align="center">&nbsp;</div>
    <p><span class="Stil1"><font face="Arial Black" color="#FF0000">
    <img border="0" src="../haerry.jpg" width="117" height="85"></font></span></p>
    <p><u><font color="#FF0000">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbs p;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; &nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&n bsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbs p;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; &nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&n bsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbs p;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; &nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&n bsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbs p;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; &nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&n bsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbs p;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;
    </font></u></p>
    </body>
    </html>

    und wie kann man die position der bilder ändern?

  8. #8
    Erfahrener Benutzer Profi Member Avatar von Jürgen
    Registriert seit
    11.11.2003
    Beiträge
    7.716

    Standard

    Hallo,

    Du hast doch nur das einzige Hintergrundbild in allen Frames mit dem Namen "rock134.jpg" und das ist das grau. Als Hintergrundfarbe ist ja schwarz notiert. Den Quelltext brauchst Du nicht posten, den sehen wir im Browser auch so.
    Tipp: Ansicht/Quelltext

    Schlimmer Quelltext ist das mit den geschützten Leerzeichen &nbsp; .

    Bis dann
    Jürgen

  9. #9
    Neuer Benutzer Newbie
    Registriert seit
    20.10.2006
    Beiträge
    18

    Standard

    aber im ZV.html habe ich noch das bild haerry.jpg und das wird nicht angezeigt...

    und wie verschiebt man die position der bilder?
    Geändert von x30er (21.10.2006 um 01:57 Uhr)

  10. #10
    Pixel
    Gast

    Standard

    Hallo x30er,

    Grafiken und Bilder mußt Du einbinden, mit einem <img src> steht Z. B. hier:
    http://www.juergens-workshops.de/ser.../einbinden.htm

    Ausrichten kannst Du auch mit CSS-angaben:
    http://www.juergens-workshops.de/ser...intergrund.htm

    und Tabellen:
    http://www.juergens-workshops.de/ser...len/aufbau.htm

    Ich empfehle dir auch HTML zu erlernen,- ist besser:
    http://www.juergens-workshops.de/ser...l811/index.htm

    charmanten Tag noch
    pixel
    Geändert von Pixel (21.10.2006 um 10:58 Uhr)

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •